Star Voyager requires the SDL portable games library to run, available for many systems at, as well as SDL_net from . Both these libraries are at version 1.2; this is the required version for running the installable binaries.
If you are compiling Star Voyager from the source code, you will also need the development packages for both these libraries, available on the same page.

The latest version has been confirmed to compile on FreeBSD, Linux and MacOS-X. Any other system with Standard C and SDL support should also have little trouble, such as Windows or BeOS.